Musings of Geekdom by Eric Newton

tail /var/log/thoughts
posts - 88 , comments - 41 , trackbacks - 68

CodeSmith NHibernate templates

...Are spitting out invalid markup...  For instance, nhibernate's schema has moved to a version 2.2. whereas CodeSmith's NHibernate templates are still spitting out 2.0...

Anybody worked with them?

Print | posted on Wednesday, July 25, 2007 2:44 PM |

Feedback

Gravatar

# re: CodeSmith NHibernate templates

If you are revering to the NHibernate template from http://www.intesoft.net/nhibernate/, then you are correct.

That template is producing classes and mappings for NHibernate version 1.0, not the new version 1.2.

To work around this issue you will need to modify the template along the lines of the NHibernate 1.0 to 1.2 migration guide (http://www.hibernate.org/407.html)
7/26/2007 2:40 AM | Jason Whitehorn
Gravatar

# re: CodeSmith NHibernate templates

create programe
3/16/2008 10:41 AM | liuhongbing
Comments have been closed on this topic.

Powered by: