News

Copyright © 2008-2019 Paula DiTallo

Tag Cloud



VS gives the error LockClrVersion, Why?

If you are getting an error message with the phrase LockClrVersion could not be located in the dynamic link library mscoree.dll  it is probably because you don't have the correct .net framework loaded. For the newer versions of C#/VB/etc.express (Visual Studio 8.0), you'll need to load the v2.0 .net framework.

If you're trying to execute Visual Studio from a location that isn't associated with your machine's installation, you'll probably move the error to some other error--at which point, a reinstall of vs will be your best bet.

Wednesday, March 12, 2008 8:52 AM

Feedback

# re: VS gives the error LockClrVersion, Why?

You can get this error even if everything is in order with all versions of .NET Framework on that machine, but you have an old version of mscoree.dll under Windows\System32 or one of the folders in the path. Replacing with version 2.0.50727.3053 or similar will solve the problem. This error means .NET Framework 2.0 and higher seems to be installed, a call to LockClrVersion is tried and fails becaus you have the old version, not supporting this function.

Of course, the .NET Framework may require reinstall, but my OS would not let me update anything, so I had to figure out other ways. Replacing the file may fix all problems or at least you can figure out what's failing next and take it from there.

Thanks AskPaula! 10/23/2009 6:36 AM | Marian Drumea

Post A Comment
Title:
Name:
Email:
Comment:
Verification: